TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 2 of 2

Thread: Unable to run Borderlands GotY on Win7

  1. #1
    Member
    Registered: Jun 2003
    Location: Darmstadt, Germany

    Unable to run Borderlands GotY on Win7

    So I've got an itch to replay Borderlands, only I can't get it to run . I played it around 2011-2012 and don't remember having any problems back then. I think I was already on Win7 back then, but I'm not 100% certain. My current install of Win7 has been running since 2014, but I haven't tried running Borderlands since 2012. In Steam when I try to start it, it says "Performing first time setup", tries to install DirectX (I have DX11) and then a few seconds later the Play button shows back up and turns green. Trying to start the executable directly shows the message "The application was unable to start correctly (0xc0000005)", no matter with what compatibility settings.

    Any idea what to do to get it to run?

  2. #2
    Member
    Registered: Jun 2003
    Location: Darmstadt, Germany
    Replying to my own thread ITT.

    I got it to work, after trying just about everything I could find on the Internet. The solution was to add Borderlands.exe to the Data Execution Prevention exclude list. Normally, Steam apps apparently can't get added to the exclusion list - I got an error message to that effect when trying to add the game. But there is a workaround (copy-pasting it here in case the original thread ever gets deleted or something):

    Quote Originally Posted by https://steamcommunity.com/discussions/forum/1/358415206084594716/
    Steam games normally can't be added to exceptions list of DEP. When you try to add them, you will get an error saying "This program must run with data execution protection", and so you must turn off DEP altogether, which I think isn't a good thing to do for your computer's sake, otherwise you won't be able to run the game. This is the case with most of the older games.

    So here's how you add steam games to that exceptions list:

    - Run regedit.exe

    - Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\AppCompatFlags\Layers

    - Right-click Layers directory and create a new string value.

    - Make that string value's name path to your game's exe,
    e.g. E:\Program Files (x86)\Steam\steamapps\common\GameName\Game.exe

    - After creating string value, right click to it and select modify then copy and paste DisableNXShowUI to "value data"

    - Go to DEP and check your exception list, game's exe should be there now. If not try again.
    - Restart computer.
    Last edited by dj_ivocha; 13th Feb 2021 at 15:07.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •