TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 5 of 5

Thread: Mission ends too early

  1. #1

    Mission ends too early

    Here's a weird one for you: I have an objective to go back to where you started once everything is done. If the player gets the required loot amount, then the loot goal completes as normal. However, if the player completes the loot goal and everything else - and then picks up another piece of loot - the game ends with all objectives checked off. Without going back to the start room.

    It's like the "leave the area" goal is secretly checking off as soon as you start the mission.

    The ending goal is goal 8. It is set up as a Final goal, so I don't know why it would be checking off early. I have deleted and re-created the ending room a couple of times (changing the room # in the objective of course).

    I've tried it with and without the TrigRoomPlayer script on the room. Now I have no other ideas except to beg for assistance. The mission goals are listed below:


    quest_create_mis goal_state_0, 0
    quest_create_mis goal_visible_0, 1
    quest_create_mis goal_irreversible_0, 1
    quest_create_mis goal_state_1, 0
    quest_create_mis goal_visible_1, 1
    quest_create_mis goal_irreversible_1, 1
    quest_create_mis goal_state_2, 0
    quest_create_mis goal_visible_2, 1
    quest_create_mis goal_irreversible_2, 1
    quest_create_mis goal_min_diff_2, 1
    quest_create_mis goal_state_3, 0
    quest_create_mis goal_visible_3, 1
    quest_create_mis goal_type_3, 3
    quest_create_mis goal_loot_3, 4000
    quest_create_mis goal_irreversible_3, 1
    quest_create_mis goal_min_diff_3, 2
    quest_create_mis goal_state_4, 0
    quest_create_mis goal_visible_4, 1
    quest_create_mis goal_type_4, 3
    quest_create_mis goal_loot_4, 3300
    quest_create_mis goal_irreversible_4, 1
    quest_create_mis goal_min_diff_4, 1
    quest_create_mis goal_max_diff_4, 1
    quest_create_mis goal_state_5, 0
    quest_create_mis goal_visible_5, 1
    quest_create_mis goal_type_5, 3
    quest_create_mis goal_loot_5, 2800
    quest_create_mis goal_irreversible_5, 1
    quest_create_mis goal_max_diff_5, 0
    quest_create_mis goal_state_6, 0
    quest_create_mis goal_visible_6, 1
    quest_create_mis goal_irreversible_6, 1
    quest_create_mis goal_min_diff_6, 2
    quest_create_mis goal_state_7, 0
    quest_create_mis goal_visible_7, 0
    quest_create_mis goal_bonus_7, 1
    quest_create_mis goal_irreversible_7, 1
    quest_create_mis goal_state_8, 0
    quest_create_mis goal_visible_8, 1
    quest_create_mis goal_type_8, 4
    quest_create_mis goal_target_8, 4011

    quest_create_mis goal_final_8, 1
    quest_create_mis goal_irreversible_8, 1

    quest_create_mis goal_state_9, 0
    quest_create_mis goal_visible_9, 1
    quest_create_mis goal_reverse_9, 1

  2. #2
    Never mind, don't waste brain power on it folks. I ran cleanobj.cmd and then input my goals again, suddenly it works. Ridiculous DromEd.

  3. #3
    Member
    Registered: Jan 2001
    Location: Constantly losing tug o'war
    The irreversible for goal 8 would have been the culprit. 'Final' just tells the game not to mark it as complete until all others are done, but the game still records it as complete, and that will stay in place if irreversible is set.

    The success of your solution suggests it was a leftover from a previous attempt, and your latest set of objective commands don't include it. The list above also has 'irreversible' set for goals 1 -7. If they're still in place, it's worth being sure they're all necessary. E.g. a loot goal shouldn't need it, unless there's some scripted event that takes away loot, like an in-game shop or a plot twist where the player's loot is stolen. A similar way of thinking applies to the other goals.

  4. #4
    Thanks R Soul because it's doing it again after making some changes...I'll try removing the irreversible on goal 8.

    Looks like that did the trick, thanks again. And if you run into the final room and quickly leave, it still ends which is good.
    Last edited by RippedPhreak; 9th May 2021 at 12:23.

  5. #5
    Member
    Registered: Dec 2004
    Location: Germany
    Interesting. Exactly the same problem was just discovered for Beltzer's "Abandoned Castle V2".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •