TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: installation fails

  1. #1
    Daxim
    Guest

    installation fails

    I try to install TN on my desktop computer:
    • Win 98SE
    • iP3 500 MHz
    • 64 MB RAM
    • ATI Rage 128
    • FortéMedia FM 801

    Config.sys
    dos=high,umb
    country=049,437,c:\windows\command\country.sys
    device=c:\windows\himem.sys /testmem ff
    device=c:\windows\emm386.exe ram highscan
    devicehigh=c:\treiber\sscdrom.sys /d:cdrom-lw /v ;Samsung CD-driver
    installhigh=c:\windows\command\mscdex.exe /e /k /d:cdrom-lw /l:e /m:4
    installhigh=c:\windows\smartdrv.exe 2048 0 ab-c+d+ef
    installhigh=c:\treiber\a-four86.com /a9 ;Mouse
    installhigh=c:\windows\command\keyb.com gr,437,c:\windows\command\keybrd2.sys
    Autoexec.bat
    @echo off
    set blaster=a220 i5 d1 t4
    set classpath=.
    set msdosdata=c:\windows\temp
    set path=c:\batch;c:\java\bin;c:\perl\bin
    set prompt=$d $t$h$h$h$h$h$h $p$g
    set temp=c:\windows\temp
    set tmp=c:\windows\temp
    c:\cfg801.exe ;initialize SB-Pro emulation
    c:\dos801.exe ;TSR for SB-Pro emulation
    mem /c-dump
    Module mit Zugriff auf Arbeitsspeicher unter 1 MB:

    Name Gesamt = Konventioneller + oberer Speicher
    -------- ---------------- ---------------- ----------------
    SYSTEM 17.488 (17K) 9.616 (9K) 7.872 (8K)
    HIMEM 1.168 (1K) 1.168 (1K) 0 (0K)
    EMM386 4.032 (4K) 4.032 (4K) 0 (0K)
    DBLBUFF 2.976 (3K) 2.976 (3K) 0 (0K)
    WIN 4.000 (4K) 4.000 (4K) 0 (0K)
    vmm32 27.776 (27K) 12.240 (12K) 15.536 (15K)
    SMARTDRV 30.480 (30K) 14.080 (14K) 16.400 (16K)
    KEYB 6.944 (7K) 6.944 (7K) 0 (0K)
    DOS801 2.336 (2K) 2.336 (2K) 0 (0K)
    SSCDROM 28.944 (28K) 0 (0K) 28.944 (28K)
    IFSHLP 2.864 (3K) 0 (0K) 2.864 (3K)
    A-FOUR86 12.864 (13K) 0 (0K) 12.864 (13K)
    MSCDEX 16.144 (16K) 0 (0K) 16.144 (16K)
    COMMAND 7.168 (7K) 0 (0K) 7.168 (7K)
    Frei 614.976 (601K) 597.568 (584K) 17.408 (17K)

    Speicherbelegung im Überblick:

    Speichertyp Gesamt = Belegt + Frei
    ---------------- ----------- ----------- -----------
    Konventionell 655.360 57.792 597.568
    Oberer 125.200 107.792 17.408
    Reserviert 0 0 0
    XMS-Speicher 65.869.552 284.400 65.585.152
    ---------------- ----------- ----------- -----------
    Speicher gesamt 66.650.112 449.984 66.200.128

    Ges. unter 1 MB 780.560 165.584 614.976

    EMS-Speicher gesamt 66.306.048 (63M)
    Freier EMS-Speicher 16.777.216 (16M)
    Max. Größe für ausführbares Programm 597.552 (584K)
    Größter freier oberer Speicherblock 12.288 (12K)
    MS-DOS ist resident im hohen Speicherbereich (HMA).
    I have plenty of free hard-disk space available.
    Symptom: After the UniVBE question the install program crashes with a page fault error and a dump of lots of processor registers. The computer stays in this videomode the install program selected (80*25, no text cursor), but is absolutely responsive.
    What I have tried so far: installed from DOS and from within the Windows GUI (by hacking the .pif files), installed from CD and from HD, answered yes and no at the UniVBE question and the possible combination of the above. If I try to install in Windows, the install program tells me that I do not have a video card that supports 640*480 (which is not true) and aborts. I can play System Shock and Duke3D through the VESA extension hardcoded into the card's BIOS. ATI has therefore no VESA driver specific for this video card. The installation in DOS 7 produces the aforementioned page fault.

    The workaround - I installed the game on my laptop computer:
    • Win98 SE
    • iCeleron 366 MHz
    • 64 MB RAM
    • NeoMagic MagicMedia
    • ESS Solo-1

    (similar boot file setup and memory distribution, the game runs fine here)
    Then I transferred the files to the HD of the desktop computer, and upon starting tn.bat the video mode changes to 40*25, a message "Crash Code: 4294967295" appears and the mentioned page fault happens again.

    Conclusion & Questions: I cannot locate the cause of the crash. This is the first unruly DOS game I've encountered so far, and I played a lot of them. Who knows what the reason might be? Who has experienced a similar problem? What could be done to solve it?

    ------------------
    Daxim's Corner

  2. #2
    James Sterrett
    Guest

    I'd love to solve your problem, but I can't. I have a broadly similar setup, and trying to install Terra Nova causes my system to crash (requires cold reboot).

    Our solution is the Total Workaround: we're worming on bringing up a P-133 that will run DOS 5. 8)


  3. #3
    belboz
    Guest

    Your computers are too fast for the program it tries to adjust for the speed and fails.

  4. #4
    Daxim
    Guest

    Honestly, that's the dumbest answer I ever received. PCs don't "adjust" for speed, I wonder how you got the idea.
    Meanwhile, I finished the game on the laptop, with the desktop computer's monitor, speaker, keyboard and mouse attached to the laptop. Marvellous, but a bit uncomfortable, each time the hassle with the cables.

  5. #5
    ACT SMILEY
    Guest

    I dunno... not sure why the graphics would be too much of a problem... My system of p3-700 rage MaXX (twin 128pro) SB live 192mb ram runs fine...

    All that I would suggest you've already tried

  6. #6
    Excoriator
    Guest

    By adjusting for speed, he means the game determines how long a series of instructions takes, and uses it as a benchmark for determining how far ahead to update each frame. Or something like that. The formula would be:

    update rate = (fixed amount of calculations) / (time to calculate them)

    and if your computer goes so fast that the granularity of the denominator causes it to round to 0, you get a nice "Divide by zero" error. I've seen it happen plenty of times on old games. Workaround is either use MOSLO.EXE or equivalent (which often doesn't work due to the fairly jerky 18.2 Hz of the slowdown routine), or unpress the "turbo" button. You have one of those, don't you?

    You can also try chilling your PC. As you know, when things get cold, they move more slowly. Also pouring syrup in the case might slow it down too.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •