TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 8 of 8

Thread: Thief Gold Graphics Problem

  1. #1
    Member
    Registered: Mar 2004

    Thief Gold Graphics Problem

    Greetings.

    I had the urge to play Thief: Gold today, so I grabbed my CD's and installed it. The problem is, when I tried to run it, I got the (apparently all-too-common now) black screen hang after pressing "continue."

    First I went to the Eidos site, which recommend turning off Hardware Acceleration. So I did that, and the game started running as normally. The only problem is that like this, the graphics totally suck.

    So I started looking around via Google and stumbled on this site. I've looked in all the relevant threads, and tried a few things:

    Originally I was using the nVidia 53.04 drivers. So I downloaded both the 45.23 drivers and the 56.54 drivers. Using the 56.54 drivers yields the same problems as 53.04. Reverting back to the 45.23 drivers is quite... interesting.

    You see, when I do that, I can finally turn on Hardware Acceleration, but when I do so, a small blurb of text appears at the top of my screen. I forget what it says at the moment, but about 15 minutes after this post I'll go back and get it. Edit - The message is "The requested screen mode could not be set." The graphics look exactly like they do with Hardware Acceleration off, with one major glaring exception: The sky is a horrid distortion of colors. Greens, yellows, purples, etc.

    I've tried adding the safe_texture_manager line to both user.cfg and cam.cfg to no avail on all three driver versions. Using the 45.23 drivers would be an acceptable solution for me, provided someone can help me make the graphics, well, stop sucking.

    System specs:
    Processor: Intel Pentium 4 2.6GHz
    OS: Windows 98SE
    DirectX: 9.0b
    Video card: Inno3D GeForce FX 5600XT.

    If anyone can shed some light on this, it would be much appreciated.
    Last edited by Nirrudn; 27th Mar 2004 at 09:40.

  2. #2
    Member
    Registered: Mar 1999
    Location: the City
    Welcome to the forum. Please take a look here.

  3. #3
    Member
    Registered: Dec 1999
    Location: Black Squadron

    Re: Thief Gold Graphics Problem

    Originally posted by Nirrudn
    The sky is a horrid distortion of colors. Greens, yellows, purples, etc
    Open cam.cfg using notepad and ensure that game_hardware is set to 1 and that game_screen_depth is set to 16. If they are not, set them to those numbers, save the file and try again

  4. #4
    Member
    Registered: Mar 2004
    Thanks for the tip David. They were set to 0 and 8 respectively, I'll change them and try it now.

    Edit - Sadly, same problem as before. I only tried this on the 45.23 drivers though. The sky is still as distorted, and the other graphics are all pixelated still. I also still get the same error message.

    Edit 2 - One more thing: Is that game_screen_depth property related to my desktop's color mode at all? Because I'm running in 32 bit color instead of 16.
    Last edited by Nirrudn; 27th Mar 2004 at 11:42.

  5. #5
    Member
    Registered: Dec 1999
    Location: Black Squadron
    No, it isn't releated to your desktop depth. As you have tried it again can you check if they have reverted back. If so set them to 1 and 16 again and make the file read only.

  6. #6
    Member
    Registered: Mar 2004
    They're still at 1 and 16. I've also left the safe_texture_manager line in there, if that counts for anything.

  7. #7
    Member
    Registered: Dec 1999
    Location: Black Squadron
    Have you run any other games since downgrading the drivers, and did you uninstall the previous set(s) prior to installing them?
    If you've not run another game can you run Dxdiag (Start > Run > Dxdiag) and make sure all three of the "DirectX Features" on the display tab are enabled and that the Direct3D tests run and complete sucessfully?

  8. #8
    Member
    Registered: Mar 2004
    Wow, how bizarre. All three Direct 3D tests fail. ("at step 8: Error creating 3D device") It also seems to be innacurately reporting the memory on my video card. It's got 256MB, but DXDiag shows it at 127MB.

    All three sets of drivers are still installed, I switch between them by going into my System properties, then the Properties of my video card. Then I use the "Update Drivers" button, the "Have Disk" option to manually select the version I want to use. I just say no if it asks me if I want to keep any newer files (if I'm reverting), and then reboot.

    Oh, and I've run one other game so far since all this started. Neverwinter Nights, if the game of choice matters at all. It ran just fine with my current drivers and such, I was playing it about 15 minutes ago.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •