TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 15 of 15

Thread: Thief Editor Error

  1. #1
    New Member
    Registered: Sep 2005

    Thief Editor Error

    I will start by saying sorry if this has already been posted.. but I havn't been able to find the answer I need anywhere on the net as yet.
    I am really intrested in making maps but I cannot get the editor to work. I have follow the wiki editor as they said.. but I still get this error:

    Viktoria: Error
    Error: Creation Failed: Factory function for tagged resource type:1242132 has not been registered!

    Error Message
    Creation Failed: Factory function for tagged resource type:1242132 has not been registered!

    Call Stack
    0x1124DA81 T3ED! (+0x44CA81)

    Register Info
    EAX=0x00000000 EBX=0x00000000 ECX=0x00000000 EDX=0x00000000
    ESI=0x00000000 EDI=0x00000000 EBP=0x0012F000 ESP=0x0012EDD0 EIP=0x10F9CA30

    System Info

    EXE Name : D:\Games\Thief3Edit\System\T3Ed.EXE
    EXE Date & Time : 15:48:58 11/17/2004
    Current Directory : D:\Games\Thief3Edit\System
    PDB File (not found) : D:\Games\Thief3Edit\System\T3Ed.PDB
    Current Date & Time : 03:32:52 PM 9/22/2005
    Username : ***
    Computer Name : ******
    OS Version : Windows 2000
    Time Since Boot : 94 hours 35 minutes 10 seconds
    Physical Memory Usage : 50
    Physical Memory (Total) : 1073201152 bytes (1023 megabytes)
    Physical Memory (Available) : 536424448 bytes (512 megabytes)
    Swapfile (Total) : 2580164608 bytes (2461 megabytes)
    Swapfile (Available) : 2171457536 bytes (2071 megabytes)
    Virtual Memory (Total) : 2147352576 bytes (2048 megabytes)
    Virtual Memory (Available) : 2068922368 bytes (1973 megabytes)

    Standard DLLs
    msvcrt.dll - Version 7.0.2600.2180 from C:\WINDOWS\system32
    msvcrtd.dll - NOT FOUND
    msvcirt.dll - Version 5.1.2600.2180 from C:\WINDOWS\system32
    msvcirtd.dll - NOT FOUND

    DirectX DLLs
    dsound.dll - Version 5.3.2600.2180 from C:\WINDOWS\system32
    dinput.dll - Version 5.03.2600.2180 from C:\WINDOWS\system32
    d3dim.dll - Version 5.1.2600.0 from C:\WINDOWS\system32
    ddraw.dll - Version 5.03.2600.2180 from C:\WINDOWS\system32
    dplayx.dll - Version 5.03.2600.2180 from C:\WINDOWS\system32

    Unreal DLLs
    Core.dll - NOT FOUND
    D3DDrv.dll - NOT FOUND
    Editor.dll - NOT FOUND
    Engine.dll - NOT FOUND
    Fire.dll - NOT FOUND
    DXAudio.dll - NOT FOUND
    IpDrv.dll - NOT FOUND
    Render.dll - NOT FOUND
    WinDrv.dll - NOT FOUND
    UWeb.dll - NOT FOUND
    Window.dll - NOT FOUND

    If anyone could help me out it would be great.
    Thank you.

  2. #2
    Registered: Apr 2005
    Location: Scotland
    Can we have some system stats, and what exactly you were trying to do before the error message came up please?

    We're still working on decoding the victoria errors, so the more info we get the more likely to offer some help we can be.

  3. #3
    New Member
    Registered: Sep 2005
    Well I used the thief3launcher which the wiki guide has told to DL.. I find the path to my editor and when I click launch it's like it will about to load editor but I get that error instead. Even if I try opening the other way that is explained on there.. I get the same thing.

    My computer stats:

    Windows XP Pro
    AMD Athlon 64 processor 3000+
    1.81 GHz
    1 gig ram
    nVidia GeForce 7800 GTX / 256MB / DDR3

    Not sure what else you would need.

  4. #4
    Registered: Apr 2005
    Location: Scotland
    I don't use the loader program, but is your processor multi-threaded at all? Maybe you need to force it to use single process for this to work.


  5. #5
    New Member
    Registered: Sep 2005
    That I am not sure of sorry.
    But that's for trying to help anyway I will just keep trying things I guess.. hopfully I can get it.

  6. #6
    New Member
    Registered: Sep 2005
    Question: Is this correct for the user.uni

    [Source Control]


  7. #7
    Registered: Apr 2005
    Location: He's behiiiind yoooou!
    That user.ini snippet looks fine to me.

    I've never seen anything like that error message before, sorry. Have you tried reinstalling stuff?

  8. #8
    New Member
    Registered: Sep 2005
    Yep, many times. :\
    I guess I will just have to stick with playing the game for now.

  9. #9
    Registered: Sep 2004
    Location: Dunno. What week is it?
    Any chance your downloaded T3Ed was corrupt?

  10. #10
    New Member
    Registered: Sep 2005
    I'm not sure. I never thought of that. I downloaded it from GameSpot.
    I shall try another version. thanks.

  11. #11
    Registered: Aug 2005
    Just a side note..

    I am surprised someone has not mentioned it but I would double check that you are using the latest Version of the nVidia drivers for your video card as well as the latest DirectX drivers from Microsoft. You had mentioned you use DX9 but is it DX9.0c? It never hurts to re-install therse drivers at any rate.

    Also be sure that you are using 32 bit color depth for your desktop resolution (ie:1024 x 768 32bbp) is what I currently use.
    T3ED won't run at a 16 bit desktop resolution in my experience although it does not return the same error, different configurations of hardware will produce different results.

    Lastly make sure you have properly set your firewall for T3ED or disable it altogether (for testing purposes). I believe KOMAG's T3ED tutorial covers firewall settings in detail. KOMAG's tut is an excellent way to get started with T3ED.

  12. #12
    New Member
    Registered: Sep 2005
    Well I just totaly reinstalled everything. I updated my drivers, re-did directx 9.c, downloaded another editor.. re-installed the game and editor.. turned off my firewall.. made sure I am 32bit and tried different res.. and still same error.

    I have a downloaded version to the game, legal.. I did pay for it through a proper site.. but I was wondering if that could be my problem somewhere? Do you need the game CD to play the game? Should I try patching something like that.. even though I don't need it.. maybe editor isn't registing it? Im really out of options

  13. #13
    Registered: Dec 1999
    Location: Black Squadron
    If you have the DirectDrive version, or whatever it is called then I would put my money on that being the problem.

    I would prefer to be wrong, though.

  14. #14
    Registered: May 2005
    Location: United Kingdom
    I read on that the Direct2Drive version of Thief III is different to the DVD Store-bought version. Maybe that's the problem

  15. #15
    New Member
    Registered: Sep 2005
    So this is an unsolveable problem then? Unless I actully buy the game..

    Thanks for all your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts