TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 6 of 88 FirstFirst ... 234567891011162126313641465156 ... LastLast
Results 126 to 150 of 2181

Thread: Please ask your basic (newbie) questions in here.

  1. #126
    Registered: Jun 2003
    Quote Originally Posted by OrbWeaver
    I think you can modify the properties in the Schema Browser, but this may change the schemas globally rather than just in your mission. It may also be possible to create your own schemas based on existing ones, but I have not investigated this myself.
    Yes, it's possible, and very simple, technically. Just go to proper directory and make a copy of whichever file you want to modify. You can then edit it in any text editor. By the way, does anyone have a good understanding of what each entry inside schema means? Changing radii worked for me, but when I tried to change ambient sound volume, there was no audible result. It would be nice to have a good tutorial available, but I don't see any on the wiki.

  2. #127
    Registered: Mar 2002
    Location: House of Sand and Fog

    Anyone break through the 7 MB 'glass ceiling' limit yet for mission sizes?

    I haven't messed around in T3Ed much, but I read about this in another thread, and suddenly, Krypts words that we'd now be able to make much bigger missions seems to be only true with the caveat that they can't surpass a 7MB limit. If there's no way to get around that, say, it's somehow hardcoded because the X-Box couldn't handle anything above that, I suppose we'll have to use more load zones than we wanted .

    Carry on .

    "I cannot see anything admirable in stupidity, injustice and sheer incompetence in high places, and there is too much of all three in the present administration." -M.M.Kaye, The Far Pavilions

  3. #128
    Registered: Mar 2004
    I believe David already posted that he ran a 40 odd meg, bafford's conversion, no probs. The 7mb limit is apparently not there.

    As for other potential limiting factors like max lights, static meshes, AI waypoints etc. It's not yet known!

  4. #129
    Registered: Mar 2005
    The "7 MB limit" is based on one person's experience with their T3Ed setup. It has not been investigated or verified scientifically, and at least one counterexample has been provided by David.

    It is known that there are certain hard limits on things like static mesh vertices, and object archetypes, but a generic 7 MB limit on total level size appears unlikely at this stage.

  5. #130
    Registered: Mar 2002
    Location: House of Sand and Fog
    Great! Thanks for the clarification, guys. Even with what little I know about these things and 'hardcoded limits', I thought it highly unlikely there'd be such an eccentric thing as limiting mission files to 7MB. I didn't hear about David's 40MB conversion! Good news (also, didn't Krypt or someone say we could potentially have very large missions, so long as we only increased the number of static meshes, and not the variety?).


  6. #131
    The Q. is was David's 40mb the unr file or not? ( as the 7mb was the unr file not the export for game)

  7. #132
    Registered: Mar 2004
    Quote Originally Posted by David
    I've imported Baffords and built the BSP on that, which has given a 12MB UNR file which I was able to reopen fine.

    I'm currently doing a "Build All" on the same file, which generated a 43MB UNR file last time I did it. (and subsequently deleted it)

    [edit] 46MB Bafford's UNR opens fine[/edit]
    There you go. Was on the first page of this thread btw

  8. #133
    Registered: Sep 2002
    Location: Pennsylvania
    Quote Originally Posted by toolman
    Think you have to have 3dsmax if you want to change a non climbable texture into a climbable one. When you're adding textures to matlibs, you can assign the material category as 'stoneclimb'.

    No idea if there's an alternate method.
    You can make individual brushes or meshes climable no matter what texture they have. You can override the material by adding the right property (but I'm too lazy to look it up at the moment).

  9. #134
    New Member
    Registered: Mar 2005
    This is a particularly embarrassing question.

    I've been using the Source Mission makin' stuff, and it has gone along just fine, however, with the T3ed, I have found that everytime I try to make hallways and rooms connected, removing the boundries of my hollow cubes I get a hallway that is fully walled and not connected at all to the room, note I've followed the tutorial directions trying to solve this problem.

    Additionally, whenever I try to place/apply textures to a wall or face of one of my cubes or other objects, it selects and then deselects the object immediately, such that I can not apply a texture. Any help or ideas would be much appreciated.

    I just fixed the problem, I'm not sure what was up with it, but I managed to get the walls to not clip into each other and now it allows me to place textures again; I suspect the one problem's solution eliminated the other problem.
    Last edited by Xon; 18th Mar 2005 at 18:44.

  10. #135
    New Member
    Registered: Mar 2005
    Xon, i'm sorry i couldn't quite understand your 1st problem, but as for having trouble selecting surfaces, it is well know that rebuilding the bsp geometery often solves the problem.

  11. #136
    Registered: May 2004
    New question (I think)

    I have installed editor ok and it works fine. I have shortcut on desktop which opens the laucher and then I can select Editor or game.

    Problem is, when I open the game with the launcher TDS is played in a window. I can full screen it with ALT+ENTER but after about a second TDS crashes with the 'send error report message'. If I run the game directly from the T3main.exe file (and not through the launcher) it runs ok in full screen.

    Obviously this isn't a major problem as I can create another shortcut on the desktop but I'd prefer not to. Has anyone else had this?

  12. #137
    Registered: Dec 2000
    Location: Finland

    Some questions:

    1. Does T3Ed have a command like persistent_player_pos which would teleport the player to a certain place when the game begins, or am I forced to move the starting point?
    2. Are there any randomizers in game that could be used?
    3. Is there anything like a create trap in T3Ed? How would I create an AI with the press of a button?
    4. I have been trying to create city respawn system in my level, but I'm obviously missing something. Is there a tutorial for this?

  13. #138
    Registered: Jun 2003
    Location: Laval, France

    Command line Ai Aware ?

    That is perhaps a stupid question but it is there for the Thief3 Editor a commande line "Ai Aware" as in Dromed ? So as to be invisible to test its mission ?

  14. #139
    Command line Ai Aware ?
    If you're using the debug version (should be) and have not remapped Backspace, hit that in game and you'll find it. I'm not at the editor right now, but it's something like AI Debugging -> Cheats -> All AIs blind, deaf and dumb. Works even to make them not see each other, not just you. I guess that has its good points and its bad points.

  15. #140
    New Member
    Registered: Mar 2005
    My in editor camera has flipped, when I look at the map everything is upside down and I can't rotate the camera so that I can see things right side up agin. If anyone knows how to fix this issue I'd much appreciate a solution.

  16. #141
    Registered: Jun 2003
    Location: Not where I'd like to be
    Okay, I've got a noob question. I see in d'Spair's tutorial that there is a short section on maps, levels, and missions. There is a statement about saving and exporting maps. I have no idea how to do this. Where are the tutorials on it. I've gone over some of the editor info, but didn't see this.

  17. #142
    Registered: Jun 2002
    Just not to bother people with problems I thought I could solve myself, I started out with the little tutorial levels and the official T3 editor setup and info -pamphlet. The first part went fine, but then I ran into a part, that skipped through essential pieces of info. I tried various approaches, but couldn't find the missing pieces.

    Here is the part I don't get:
    Travelling To and From other Maps
    Starting with: Tutorial2.unr

    Create a travel volume (for out-going level changes):
    1. In the small hallway on the right, adjust the builder brush so that it’s a little smaller than the hallway, so that the volume will be distinct.
    2. Create a Volume (this is the 7th and final of the brush building icons on the left toolbar. It looks like a 3D translucent blue cube). Select “volume” (generic) as the volume type.
    3. Right-click on the volume and choose “Volume Properties”
    4. On the bottom line of the property window, where it says “Properties”, right-click and choose “Add Property”.
    What needs clarifying:
    1. Where is the "builder brush", and what is it supposed to be? I managed to shrink the red thingie-selector by adjusting the numbers from the green cube-icon. What does that red frame do? Where are the safety labels?!
    2. I click (both left and right) on the blue cube (volume), and choose the volume -text: nothing happens.
    3. I right-clicked on the volume already (the icon), and there is no volume properties!

    Someone should write a better tutorial for people like me. (whether the problem is me or the manual...)

  18. #143
    Registered: May 2001
    Location: Finland
    The builder brush is the red square that you initially see. I was initially a bit confused by how it works, too. The thing to understand is, it is always there. The builder brush can't be deleted, only moved out of the way.

    When you want to build geometry, and starting out from scratch, what you initially have is a world that is entirely solid. You need to carve out your space out of that using the builder brushes (you can add to already carved spaces, too).

    That red thing is the builder brush, and it is what defines the geometry of the space that you wish to build (either add or subtract). Let's consider just subtracting for now.

    By right-clicking on that green cube icon, you have already accessed the geometrical properties of the cube. There you can define the dimensions of that shape. There are also other geometrical primitives available, like a sphere, a cylinder, a cone etc., and each has a set of properties that you can modify. Modifying the properties by hand isn't the only option of changing the shape of your selected geometric primitive. Search the tutorials for 'Vertex Editing' to learn more.

    When you've defined the dimensions of the cube you wish to build, you position the builder brush where you want it, and click on the "Subtract" icon. That's when the shape is subtracted from the world (that is initially entirely 'solid') and your Binary Space Partition (BSP) / Constructive Solid Geometry (CSG) is built.

    At this point you should see a 3D cube like object with a default texture appear in the 3D viewport. In the 2d viewports nothing seems to have happened. The red builder brush is still there, and it's visible also in the 3D viewport. Not to worry, it's supposed to stay there. Your cube has been subtracted, but you need to move the builder brush out of the way to see it. So go into one of the 2D viewports, click on the builder brush to select it (see that it turns bright red), press down ctrl, and drag the brush to the side with the mouse to reveal the 'room' you just built.

    The 'Volume' icon is used to create volumes of water etc., I think -- read from the tutorials, I don't recall precisely how that works.

    The builder brush just acts like a resizeable, shapable mold, that's always hanging around ready to be used.

  19. #144
    Wow theres a lot of stuff here. If you found any bugs or have issues with my launcher let me know via a Private Message, otherwise I'll never know. I'm planning a bug-release sometime soon once I get some more reports.

  20. #145
    Registered: Jun 2003
    Location: Not where I'd like to be
    Question on Tutorial Teleport setup...

    I was going through the 5 tutorial maps last night. I built a teleport volume that took me back to my own level. Worked fine. The next step was to add a button that changes the location of the teleport. I setup the triggerScript, added the teleport values, and ran the level. But nothing happens when I press the button. The teleporter still takes me back to my own level rather than the new level (SouthQuarter) that is specified in the triggerScript. Is there something obvious that I am doing wrong. The steps, as I understand them, are:

    1) Place link
    2) Create trigger script
    3) Add trigger script to button
    4) When pressing button, the triggerScript applies to the teleport volume and changes the 3 teleport properties.

    I get no errors when I hit the button or run the map. Is it possible that a setting is wrong (I doubt it, though).


  21. #146
    Registered: Jun 2003
    Location: Not where I'd like to be
    Quote Originally Posted by 2003MINI
    Question on Tutorial Teleport setup...
    Nevermind. I think my PC was working too hard yesterday. When I ran it today. It worked.

  22. #147
    New Member
    Registered: Mar 2005

    help starting editor

    whenever i click on the T3Ed icon to start the editor a message pops up saying that i need to start the editor from T3.exe with the commandline argument "editor" what should I do?

  23. #148
    You might be missing step 12 from Installation.

  24. #149
    New Member
    Registered: Mar 2005

    How do you install the editor? I can't find any instructions for it.

    I downloaded the thief editor and unzipped it onto a different harddrive then what thief 3 is on. I would imagine that I need to unzip it somewhere in particular but I can find no instalation instructions. the Editor does not come with a readme file.

    I see that several people have had problems with installing the editor. So far it does not work for me, but that is saying nothing, becuase I don't know and can not find how it should be properly installed to begin with.

    Can someone help please?


  25. #150
    Registered: Dec 1999
    Location: Black Squadron
    Try the link in the post directly above yours.

Page 6 of 88 FirstFirst ... 234567891011162126313641465156 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts